Skip to main content

TRACE USB access locked by other GUI - Community / Other Use Cases - Lauterbach Support


TRACE USB access locked by other GUI


My T32 GUI was hanged and I had to force close it. Please note I was using a USB proxy on remote system during that time. It seems that forcefully closing trace32 GUI left the USB access marked as in use without freeing it. Now Trace32 does not starts and closes with the following error,

"FATAL ERROR from PODBUS-driver: TRACE USB access locked by other GUI." See attached file.

I have tried to restart my workstation and the issue still persists.
Please advise.

Thank you.

Comments (2)

Muhammad Osaid
Cannot find place to attach file. Here is a text sample Window Title: TRACE32 PowerView for Tricore 0 [Power Debug USB3 @ ] Message: FATAL ERROR from PODBUS-driver: TRACE USB access locked by other GUI. Please note un-installing and reinstalling also does not fix the problem.
Muhammad Osaid
Solution: Restart the previously running TCP proxy service on remote machine as well. (t32tcpusb.exe) Normally if the GUI closes gracefully it would release the USB access lock and the TCP proxy service running on remote computer would be available to be used again. When original issue occurred the already running TCP proxy service was locked by the GUI which was forcefully closed. So despite starting T32 / reinstalling T32 on developer system the previous USB lock on remote system remained. Simply restarting the TRACE32 TCP USB Proxy Service on remote system would start the service fresh and make itself available to be locked for new USB locking requests. This issue is solved.

Add a comment

To prove you are a human, please tell us the text you see in the CAPTCHA image